ホーム > スポンサー広告 > スポンサーサイト> Zen Cart > Zen Cart(ゼン・カート)をPHP5&MySQL5で動かす

スポンサーサイト

--年--月--日

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
関連タグ:
ソーシャルブックマークに追加: Google Bookmarks に追加 はてなブックマークに登録する Yahoo!ブックマークに登録する Buzzurlにブックマーク登録する FC2ブックマークに登録する livedoorクリップに登録する newsingブックマークに登録する イザ!ブックマークに登録する del.icio.usブックマークに登録する
【--/--/-- --:--】 | スポンサー広告 | page top↑

Zen Cart(ゼン・カート)をPHP5&MySQL5で動かす

2008年06月24日

最近のオープンソースCMSは、PHP5MySQL5.x系でも動くものが増えていますが、現在のZen Cart(ゼン・カート)日本語版の最新バージョン(1.3.0.2)は、PHP4とMySQL4.xの環境下でしか、正常に動きません。本家Zen Cartのバージョン1.3.8も、同じくPHP4とMySQL4.x系のようです。次期バージョンZen Cart1.4系では、PHP5MySQL5.x系に対応するようです。


しかし、最近のサーバ事情からすると、PHP5MySQL5.x系でも動作して欲しいものです。今後のレンタルサーバの仕様がPHP5MySQL5.xが中心になっていく事を考えると、初めから、PHP5MySQL5.x系で動かしていた方が、運用後のことを考えると安心といえるでしょう。

もしも、PHP4とMySQL4.xで運用していて、途中から、PHP5MySQL5.x系に変更しなければいけなくなると、相当な覚悟が必要です。Zen Cartのプログラムやデータベースなどを修正するか、サーバ会社を変えるかのどちらかになると思います。前者は、運用中プログラムの修正は非常に難しく慎重に作業を行う必要があります。後者の場合は、時期バージョンの1.4系がリリースされると、サーバ会社もそのような仕様になるので、探すのが難しくなってくるでしょう。


しかし、PHP5MySQL5.x系で動作するZen Cart 1.3.8バージョン、しかも日本語版が手にはいるのです。「有限会社ビッグマウス」のウェブサイトでPHP5MySQL5.x対応Zen Cartがダウンロードでき、それ以外にも無料モジュールもダウンロードできます。


本家のオフィシャルではありませんが、問題なく動きます。しかも、無料モジュールまで付いてきます。実際、私自身使っています。自分のローカル環境をXamppの最新バージョンに変えた際に、Zen Cartが正常に動かず、いろいろ探した結果「有限会社ビッグマウス」さんのウェブサイトにたどりつきました。


ビッグマウスさんは、Zen Cartのモジュール販売などをされていてるので、追加機能など必要があれば、ビッグマウスさんにお願いすれば、大抵のことはやってくれそうです。(有料ですが)


まあ、現在のZen Cart本家バージョンが1.3.8ということを考えると、1.4系がリリースされるのも近いので、それまでは現行バージョンのままを使っても良いかもしれません。



関連サイト


関連記事


↓ブログランキングに参加中!読み終わったらクリックお願いします↓
にほんブログ村 IT技術ブログへ 人気ブログランキング FC2 Blog Ranking
関連タグ:オープンソース CMS Zen Cart サーバ PHP5 MySQL5
テーマ:ホームページ・ブログ制作 - ジャンル:コンピュータ
ソーシャルブックマークに追加: Google Bookmarks に追加 はてなブックマークに登録する Yahoo!ブックマークに登録する Buzzurlにブックマーク登録する FC2ブックマークに登録する livedoorクリップに登録する newsingブックマークに登録する イザ!ブックマークに登録する del.icio.usブックマークに登録する
【2008/06/24 09:24】 | Zen Cart | トラックバック(0) | page top↑
トラックバック
トラックバックURL
→http://opensourcecms.blog122.fc2.com/tb.php/31-c2678896
この記事にトラックバックする(FC2ブログユーザー)
| ホーム |
ブログパーツ
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。